[Logo] VUE Users Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
[Login] Login 
If this is your first visit to the new VUE forums, you can login using the same username and password you currently use on VUE's website. If you need an account, please create one through VUE's website. If you have problems, please contact us via the contact form on http://vue.tufts.edu
Ontology bug?  XML
Forum Index » Technical Problems and Bug Reports
Author Message
Neil Pilgrim


Joined: 09/01/2008 10:58:24
Messages: 19
Offline

Hi,

This is in version 2.2.8.

a) Add the elements ontology and stylesheet from the website
b) Create new node (label does not matter)
c) Assign it an ontological term (eg. 'Element')
d) Click elsewhere in map to deselect
e) Double-click on node/label to edit the label
f) label text cannot be edited!
the label and node appear to become detached?
VUE is stuck in 'edit label mode'!
files can't be saved/closed/opened!

Note that if step (d) is omitted, with the node text being edited straight away, then this problem doesn't appear to arise, but that the only way to get out of the stuck program is to quit.

Dragging ontology elements to the map appears to work ok though.

(I'm not sure I understand the styling - eg. removing an ontology term from an arrow and adding a different one (ionic->covalent) does not change the styling?)

--
Neil
Daniel Heller


Joined: 08/08/2008 11:36:13
Messages: 24
Offline



i'm looking into trying to reproduce your bug, so far without success -- could you go to the help menu and look at your VUE Log?

If possible, attaching the contents of your vue log after you see the bug to a reply email would be helpful..

in step d, is the node tool still selected or have you switched back to the selection tool? (I haven't been able to reproduce in
either case as of yet)

as far as changing styles -- the style does not currently change from applying new ontological membership -- after
the initial styling from the panel multiple ontological memberships can be applied, but only the original styling remains (also
any changes you make in styling persist even if you remove the ontological membership..)

you can, however, create a new node/link with the new style and copy the style over to the original node/link
through the edit menu.
Neil Pilgrim


Joined: 09/01/2008 10:58:24
Messages: 19
Offline

Hmm, looks like some fun null pointers ;)

-------------------------
VUE 2008-09-16 13:45:40,799 INFO [Thread-1] VUE: VUE build: July 2 2008 at 1658 by vue on Linux 2.4.21-53.EL i386 JVM 1.5.0_06-b05
VUE 2008-09-16 13:45:40,801 INFO [Thread-1] VUE: Current Platform: Linux 2.6.24-etchnhalf.1-amd64 i386
VUE 2008-09-16 13:45:40,802 INFO [Thread-1] VUE: Running in Java VM: 1.5.0_11-b03; MaxMemory(-Xmx)=918.7M, CurMemory(-Xms)=25.9M, FreeMemory=8.2M
VUE 2008-09-16 13:45:40,802 INFO [Thread-1] VUE: VUE version: 2.2.8
VUE 2008-09-16 13:45:40,802 INFO [Thread-1] VUE: Current Working Directory: /home/npilgrim/VUE
VUE 2008-09-16 13:45:40,802 INFO [Thread-1] VUE: User/host: npilgrim@null
VUE 2008-09-16 13:45:43,166 INFO [Thread-1] VUE: startup completed.
VUE 2008-09-16 13:45:43,332 INFO [Thread-1] [DSV] DataSourceViewer: Loading old style data sources...
VUE 2008-09-16 13:45:43,772 INFO [Thread-1] [DSV] [vds] [XML] Mapping: Loading mapping descriptors from jar:file:/home/npilgrim/VUE/VUE.jar!/tufts/vue/resources/lw_mapping_1_1.xml
VUE 2008-09-16 13:45:45,217 INFO [Thread-1] [DSV] DataSourceViewer: Loaded old style data sources.
VUE 2008-09-16 13:45:45,217 INFO [Thread-1] [DSV] DataSourceViewer: loading Installed data sources via Data Source Manager
VUE 2008-09-16 13:45:45,218 INFO [Thread-1] [DSV] [LD] VueDataSourceManager: Installed datasources not found
VUE 2008-09-16 13:45:45,218 INFO [Thread-1] [DSV] DataSourceViewer: finished loading data sources.
VUE 2008-09-16 13:45:45,299 INFO [Thread-1] UrlAuthentication: Fetching VueDataSourceManager
VUE 2008-09-16 13:45:45,299 INFO [Thread-1] UrlAuthentication: Fetching Sakai data sources from VDSM
VUE 2008-09-16 13:45:45,300 INFO [Thread-1] UrlAuthentication: Done loading authentication keys.
VUE 2008-09-16 13:45:45,301 INFO [AWT-EventQueue-0] [dsv-cache] DataSourceViewer: requesting viewer for: tufts.vue.LocalFileDataSource@1c9ce70[My Computer; ]
VUE 2008-09-16 13:45:45,311 INFO [version-check] VUE: Checking for latest version of VUE
VUE 2008-09-16 13:45:45,312 INFO [Thread-1] VUE: main complete
VUE 2008-09-16 13:45:45,320 ERROR [version-check] VUE: Error Checking latest VUE releasevue.tufts.edu
VUE 2008-09-16 13:45:45,333 INFO [AWT-EventQueue-0] [dsv-cache] DataSourceViewer: requesting viewer for: tufts.vue.FavoritesDataSource@075be38[My Saved Content; null]
VUE 2008-09-16 13:45:45,691 WARN [VBLD-01 FavoritesDataSource[My Saved Content]] GUI: could not get Icon for filetype: dir.16; java.lang.NullPointerException: no Image; fsIcon=javax.swing.plaf.IconUIResource@13a3d36
VUE 2008-09-16 13:45:45,706 WARN [VBLD-00 LocalFileDataSource[My Computer; ]] GUI: could not get Icon for filetype: vpk.16; java.lang.NullPointerException: no Image; fsIcon=javax.swing.plaf.IconUIResource@106def2
VUE 2008-09-16 13:45:45,707 WARN [VBLD-00 LocalFileDataSource[My Computer; ]] GUI: could not get Icon for filetype: zip.16; java.lang.NullPointerException: no Image; fsIcon=javax.swing.plaf.IconUIResource@106def2
VUE 2008-09-16 13:45:45,708 WARN [VBLD-00 LocalFileDataSource[My Computer; ]] GUI: could not get Icon for filetype: exe.16; java.lang.NullPointerException: no Image; fsIcon=javax.swing.plaf.IconUIResource@106def2
VUE 2008-09-16 13:45:45,708 WARN [VBLD-00 LocalFileDataSource[My Computer; ]] GUI: could not get Icon for filetype: lnk.16; java.lang.NullPointerException: no Image; fsIcon=javax.swing.plaf.IconUIResource@106def2
VUE 2008-09-16 13:45:45,708 WARN [VBLD-00 LocalFileDataSource[My Computer; ]] GUI: could not get Icon for filetype: desktop.16; java.lang.NullPointerException: no Image; fsIcon=javax.swing.plaf.IconUIResource@106def2
VUE 2008-09-16 13:45:45,709 WARN [VBLD-00 LocalFileDataSource[My Computer; ]] GUI: could not get Icon for filetype: bin.16; java.lang.NullPointerException: no Image; fsIcon=javax.swing.plaf.IconUIResource@106def2
VUE 2008-09-16 13:45:45,712 INFO [VBLD-00 LocalFileDataSource[My Computer; ]] DataSourceViewer: produced VueDragTree(My Computer)
VUE 2008-09-16 13:45:45,728 WARN [VBLD-01 FavoritesDataSource[My Saved Content]] GUI: could not get Icon for filetype: dir.32; java.lang.NullPointerException: no Image; fsIcon=javax.swing.plaf.IconUIResource@13a3d36
VUE 2008-09-16 13:45:45,728 WARN [VBLD-01 FavoritesDataSource[My Saved Content]] GUI: could not get Icon for filetype: dir.16; java.lang.NullPointerException: no Image; fsIcon=javax.swing.plaf.IconUIResource@13a3d36
VUE 2008-09-16 13:45:45,728 WARN [VBLD-01 FavoritesDataSource[My Saved Content]] GUI: could not get Icon for filetype: dir.32; java.lang.NullPointerException: no Image; fsIcon=javax.swing.plaf.IconUIResource@13a3d36
VUE 2008-09-16 13:45:45,728 WARN [VBLD-01 FavoritesDataSource[My Saved Content]] GUI: could not get Icon for filetype: dir.16; java.lang.NullPointerException: no Image; fsIcon=javax.swing.plaf.IconUIResource@13a3d36
VUE 2008-09-16 13:45:45,730 INFO [VBLD-01 FavoritesDataSource[My Saved Content]] DataSourceViewer: produced FavoritesWindow@d6ee28
VUE 2008-09-16 13:45:46,771 INFO [Thread-9] CategoryModel: no custom meta-data: /home/npilgrim/.vue_2/custom.rdfs (No such file or directory)
Daniel Heller


Joined: 08/08/2008 11:36:13
Messages: 24
Offline



hmm... looks like this could be a linux specific bug.

so, you are able to save files before you try any of the ontology application?

I'm actually surprised to not see *more* errors considering the behavior you are seeing, may have to refer this to one of our in house linux expert(s) -and/or
look for a linux machine/vm to run -- at first glance the error you are getting appears to perhaps affect the file dialog.. but it seems like it would
do so regardless of any ontology features you might be using..

am I correct that you are running linux? And, if so, what variety?

sorry its acting so strangely! We will continue to investigate..
Neil Pilgrim


Joined: 09/01/2008 10:58:24
Messages: 19
Offline

This bug was found on Debian etch, on a dual core (core2) intel chip, running in 64-bit mode, kernel 2.6.24-etchnhalf (*cough* 2.6.24 + debian tweaks).

The VUE was an 'installer' version for linux - frankly I was happy that anything worked ;)

I do have 32-bit libs installed - 'ldd' on jre/bin/* gives redirections to lib32 versions.

Basically after I've clicked away to deselect the node, then double click to edit the text *in* the node, its like its enabled some 'modal' flag. The open/close/save/... entries in the File menu are all greyed out.

Let me know if you need to know more!
 
Forum Index » Technical Problems and Bug Reports
Go to:   
Powered by JForum 2.1.8 © JForum Team