[Logo] VUE Users Forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
[Login] Login 
If this is your first visit to the new VUE forums, you can login using the same username and password you currently use on VUE's website. If you need an account, please create one through VUE's website. If you have problems, please contact us via the contact form on http://vue.tufts.edu
Vue 2.3.1 crashes on launch  XML
Forum Index » Technical Problems and Bug Reports
Author Message
Andrew Robinson


Joined: 05/06/2009 17:13:06
Messages: 5
Offline

Hello there

I have just downloaded Vue 2.3.1 (as a new user) and it crashes on launch.
The dialog box "Vue init failed" pops up with the following error messages:

java.lang.RuntimeException: C:\Users\adm1n\vue_2:cannot be created
at tufts.vue.VueUtil.getDefaultUserFolder(VueUtil.java:165)
at tufts.vue.Images.getCacheDirectory(Images.java:1065)
at tufts.vue.Images.loadDiskCache(Images.java:1083)
at tufts.vue.VUE.initApplication(VUE.java:1217)
at tufts.vue.VUE.main(VUE.java:993)
at tufts.vue.SingleInstance$2.run(SingleInstance.java:94)

I'm running the latest version of Java, build 1.6.0_13-b03


Any ideas?

Andrew
Mike Korcynski

[Avatar]

Joined: 08/08/2008 11:36:13
Messages: 749
Offline

It didn't have permission to create that file on your computer. It needs to be able to create that directory in order to store configuration data.

-Mike
Andrew Robinson


Joined: 05/06/2009 17:13:06
Messages: 5
Offline

Thanks for the quick reply Mike.

I manually created the vue_2 folder in the users folder (I do have admin privileges ) and the launch process got a little further along this time

The error dialog now says:

java.lang.NullPointerException
at tufts.vue.Images.loadDiskCache(Images.java:1089)
at tufts.vue.VUE.initApplication(VUE.java:1217)
at tufts.vue.VUE.main(VUE.java:993)
at tufts.vue.SingleInstance$2.run(SingleInstance.java:94)

So, now what do I do?


Andrew
Mike Korcynski

[Avatar]

Joined: 08/08/2008 11:36:13
Messages: 749
Offline

Andrew,

Sorry for the lag in reply I've been poking around in Vista to see how you've ended up with this problem without much luke. The next problem you've encountered is that it wants to create a subdirectory called 'cache' off the vue_2 folder, did it manage to create teh Datasources.xml file under the vue_2 folder once the folder was created?

Mike
Andrew Robinson


Joined: 05/06/2009 17:13:06
Messages: 5
Offline

Hi again Mike


I created the "cache" folder manually. The XML file was not present. Then I tried again and.... YAY, I get the Vue: New Map screen.

Hopefully that solves the problems.

Don't you just love Vista when it does that to you....


Thanks for all your help

Andrew
Mike Korcynski

[Avatar]

Joined: 08/08/2008 11:36:13
Messages: 749
Offline

Andrew,

Glad to here this may be resolved. If the datasoruces.xml file isn't getting created I'm still a bit skeptical, if you have any other problems you may want to right click VUE-Launcher.exe, click the compatibility tab and try selecting "Run this program as administrator", I'd be curious if that would resolve this.

Good luck, let me know if you run into any other problems.
Mike
Andrew Robinson


Joined: 05/06/2009 17:13:06
Messages: 5
Offline

Hi again Mike

I tried making a very simple map and saving it, and that went okay. The XML file still wasn't there!

Then I tried your tip of running as administrator. Now the datasources.xml and extensions.xml files get created in the vue_2 folder.

Do I always need to run Vue as the administrator, or can I just run it as a "normal" user once the files are created?


Andrew
Mike Korcynski

[Avatar]

Joined: 08/08/2008 11:36:13
Messages: 749
Offline

Andrew,

My thought at the moment is that you'll want to run it as admin for now, I don't yet understand why vista permissions have affected your VUE differently then others. My thinking is that if you don't do this basic mapping will work fine, but if you start using images on nodes, they won't cache properly because VUE won't be able to create images in the cache, you probably won't be able to add new Datasources if you try to use that feature, and preferences will not be persisted between VUE launches.

-Mike
Andrew Robinson


Joined: 05/06/2009 17:13:06
Messages: 5
Offline

Mike

I am running Vista Enterprise version - I wonder if this makes a difference - maybe the "admin" privileges for users are not the same as a genuine Administrator.

I'll run as Admin for now.

Thanks again

Andrew

This message was edited 1 time. Last update was at 05/08/2009 14:21:39

Brendan Prusik


Joined: 12/01/2012 09:12:33
Messages: 3
Offline

I am having this same problem tried to create the subfolders manually and run as admin. No joy
Using Windows 7 pro
The error I get is
java.lang.RuntimeException: C:\Users\mine\box sync\documents\vue_2:cannot be created
notice that the address is slightly different than the previous user
Box Sync is installed to backup all of my user files but is not directly accessible using windows explorer
I can access C:\Users\mine\documents\ but not the address listed above.
 
Forum Index » Technical Problems and Bug Reports
Go to:   
Powered by JForum 2.1.8 © JForum Team